Hinweise zum Import von: / Hints for importing:

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

I am trying to import stp file that was exported from GMSH as stp file.
Importing is good and I can see stl visualisation of the model.

The problem is when I try to mesh it using either netgen or tetgen I get an error "Only one part can be meshed". I checked GMSH for the number of solids in the file and there are only 1.

I am attaching .geo file which is GMSH file, STP file that was exported and the project folder as zip file.

Any help would be much appreciated.

Kind Regards
(784.95 KiB) 75-mal heruntergeladen
(127.86 KiB) 68-mal heruntergeladen
(348 Bytes) 80-mal heruntergeladen
Hello datsnl,

the problem is, that your step file holds more than just one part, due to the fact, that some surfaces are included mutiple times.
I attached a fixed version of your stp file.

Kind regards,
(414.93 KiB) 81-mal heruntergeladen
Hello FHueter,

try to mesh a geometry within z88 facing problems with surfaces included multiple times (... only one part can be meshed). How did you fix the stp-file? I tried to export the model using different formats but with more or less the same result. The only way to mesh successfully is to set the max. elemtsize to a very low level thus get a mesh with a huge elementnumber and running out of memory... .

best regards
(317.54 KiB) 17-mal heruntergeladen
(611.6 KiB) 17-mal heruntergeladen
Hello Flettner,

your step file contains more than a single part. Therefore, the meshing seems to fail.
We meshed your part with a commercial software, which is able to handle the problem.

We attached the file for import to Z88.

best regards
(8.31 MiB) 10-mal heruntergeladen
Hello chgl,

first of all thank you for help. How do you recognise that it consist of more than one part and what's the commercial software to handle this?
I'm still interested in how to recognise the number of parts and how to repair broken files. For future studies it is necessary that I'm able to check.

Hello Flettner,

we used the software abaqus. So we could connect the surfaces.
Overall, it seems to be an export problem. There should be no facets, your part must be exported as a solid. See attached configuration.

best regards
(2.18 KiB) 10-mal heruntergeladen
Einstellungen.PNG (11.78 KiB) 288 mal betrachtet
Z88Aurora V5 released

Hey Dave, thank you for your feedback. We are gl[…]

Hallo Herrjakel, Ihr System ist eigentlich schon […]

Hallo ich versuche ein eine etwas komplizierteres[…]

3D spacecontroller

Da die Oberfläche von Z88Aurora weiterhin auf[…]