Hinweise zum Import von: / Hints for importing:

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

I can't import a .inp file because it says

# More than one element type was found
# Z88Aurora can import only one element type
# Shut down z88inp

But the file has only one element type (C3D4). I get the same error with C3D10 and also with Z88Arion. So what are the rules for a .inp file to be compatible with Z88Aurora? Or are there example files that it can import?

I've attached a failing .inp file. Renamed to .pdf to allow the forum to accept it.
(10.62 KiB) 233-mal heruntergeladen
Dear Zambozi,

your keywords do not match.
To make it work, either change the keywords in your INP file or in the inpenviro.z88 file in the binary folder of your Z88Aurora installation.

You use:
*Node and *Element, type=C3D4

Please refer to theory manual page 106 and following (4.1.9 THE ABAQUS CONVERTER Z88AINP).

Kind regards,
Unfortunately I wasn't involved in the development of the Abaqus converter, so I can't tell why it's case-sensitive. If your software always exports INP files with capital letters, you only need to alter the file inpenviro.z88 once and it will work for all your INP files.
I will submit a request to our developers and eventually there will be an update of the converter in one of the next releases of Z88Aurora.

Kind regards,
Stefan! :mrgreen:
I've got a similar problem. I made a mesh in gmsh (export as .inp) and want to do a modal analysis in z88. I defined one physical volume, so I have only one element type. I also deleted the surface elements, which are saved by gmsh automatically. I also changed the case sensitive keywords. I can import the mesh now , but I can't calculate anything, because I get this error in the console:

### Jacobi-Determinante Null oder negativ..Stop ###
### Elemente zu verzerrt oder falsch numeriert ###
### pruefen, Numerierung gegen Uhrzeigersinn? ###

Now I am wondering, if there is something wrong in with the element numbering in gmsh? Do I have to do something additionally to import this mesh in the right way? In gmsh I used the default parameters for meshing.

Hey ClaKe!
thank you for your answer!

I exported the mesh from gmsh as .inp - Abaqus file, because z88 can import Abaqus files.
The model is displayed after the import. I will send the .inp file (renamed it inp_mesh.pdf; I hope that works), and the .geo file from gmsh (gmsh_geo_file.pdf)

I now tried another option: I exported a .nas file from gmsh and trief to import it in z88. When I use a very simple geometry, like a sphere, I can inport the mesh in z88 and I can also do the modal analysis. With my mesh (tube-shape) this doesn't work (I couldn't send it, it is too big)

(440 Bytes) 102-mal heruntergeladen
(7.36 MiB) 120-mal heruntergeladen
Hello chimy164,

we examined the mesh. It was noticed that over 8000 elements are not calculable. This can happen if the geometry of these elements is very distorted. So the mesh has numerical problems and can not be used. One reason can be the very fine mesh size. Is this fine mesh necessary. Try to export the mesh with a very rough size. If the nas-file work why do not use nas for your part.

I have imported step file.
As i try to mesh with netgen ...the software hangs & crash.

Even tried with stl file...same happens...crash.

Kindly guide, your software is very good as we can define loads in multiaxis with great ease....but mesh generation is problem. Below message appears in terminal.

I am new user to your software, kindly guide.

INFO (30020): Z88Aurora: Status: started!
Memory required: 574 MB

(z88aurora:12485): GLib-GIO-CRITICAL **: 14:12:28.218: g_dbus_proxy_new: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(z88aurora:12485): Gtk-CRITICAL **: 14:12:49.792: IA__gtk_widget_grab_default: assertion 'gtk_widget_get_can_default (widget)' failed

(z88aurora:12485): Gtk-CRITICAL **: 14:14:13.879: IA__gtk_widget_grab_default: assertion 'gtk_widget_get_can_default (widget)' failed
Drehpunkt am Scharnier

Hallo, ich bin neu hier und möchte hier mal […]

vielen Dank für die Info - als Workaround ist[…]

Hallo AZahn, vielen Dank für deine Hilfe. Ic[…]

Hello roland, I guess you tried to use beam eleme[…]