Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

#3443
Hallo zusammen,

vor kurzem habe ich mein OS komplett auf Linux Ubuntu umgestellt.
Z88 hat unter Windows problemlos funktioniert. Nach der Installation
unter Ubuntu kam erst ein roter Hintergrund. Das Problem ist nun behoben.
Allerdings scheint der Solver Probleme zu haben:

-----------------------------------------
Z88R2A Version 1.0 Apr 12 2017 14:10:03
-----------------------------------------
# Kann z88o2.txt nicht oeffnen
# Kann z88o4.txt nicht oeffnen
# Kann z88o5.txt nicht oeffnen
# Kann z88o8.txt nicht oeffnen
# Keine Kontaktknoten vorhanden + Keine Verschiebungsergebnisse gefunden
+ Keine Kraftergebnisse gefunden
+ Keine Spannungsergebnisse gefunden
+ Speicher Knotenergebnisse anfordern
+ z88arn.bny geschrieben
+ Speicher Elementergebnisse anfordern
+ Speicher Gausspunktergebnisse anfordern
-----------------------------------------
Z88R2A erfolgreich beendet 14:10:03
-----------------------------------------

Weiß jemand an was das liegen könnte?

Da ich vermute, dass das noch mit der Installation zusammenhängt,
habe ich mich für diese Rubrik entschieden.

Viele Grüße
Ralph
#3444
Hallo Ralph,

da gibt's zwei Möglichkeiten: der Solver schreibt keine Ergebnisdateien, weil er keine Zugriffsrechte hat oder der Konverter (R2A) kann die Dateien nicht lesen, weil er keine Zugriffsrechte hat :lol:

Also irgendwas mit den Zugriffsrechten wird nicht stimmen. Kuck nochmal ins Installationshandbuch, da steht drin wie die korrekt zu setzen sind. Idealerweise bekommen alle Binaries (ausführbare Dateien) unter /bin/ubuntu64 volle Lese- und Schreibrechte (CHMOD 777). Damit sollten die Probleme verschwinden. Falls die dann noch da sind, einfach wieder hier melden. Interessant wäre, ob während der Fehlermeldung (nicht auf OK drücken nach Solverlauf) die Dateien im Projektverzeichnis vorhanden sind. Da einfach mal nachkucken.

Beste Grüße,
SHautsch
#3446
Hallo SHautsch,

vielen Dank für die schnelle Rückmeldung.

Leider funktioniert es auch mit den Zugriffsrechten nicht.
Die LOG-Datei wurde ins Projektverzeichnis geschrieben.
In der GUI selber kommt nur die Popup-Fehlermeldung:

Solverinfo: Fehler: Z88R!
Siehe bitte z88r.log!

Leider gibt es kein File dass genau diesen Namen hat.
Die Meldung im erstem Post habe ich aus der Datei
z88ro2ag.log.

Gibt es noch etwas was ich tun könnte?

Viele Grüße
Ralph
#3447
Hallo Ralph,

also der Solver selbst läuft schon nicht - dann liegt es nicht am Konverter.
Kannst du uns das Projekt irgendwie zukommen lassen, damit wir uns das genauer ansehen können?
Entweder das Projektverzeichnis gezippt hier hochladen oder per E-Mail an z88aurora-ädd-uni-bayreuth.de senden.

Beste Grüße,
SHautsch
#3449
Hallo RalphG,

also das Projekt rechnet bei mir (auf Windows) ohne Probleme, liegt also nicht am Projekt selbst.

Daher muss der Schuldige die Z88Aurora-Installation sein. Was gibt denn die Konsole aus, wenn der Fehler auftritt? Gerne davon mal einen Screenshot hier reinstellen.

Und dann evtl. die Zugriffsrechte nochmal kontrollieren bzw. hier auch nen Screenshot davon beifügen, damit sich da nicht noch ein Fehler eingeschlichen hat.

Beste Grüße,
SHautsch
#3452
Hallo SHautsch,

im Anhang ein Screenshot der Konsolenausgabe und der Dateien wo ich
die vollen Zugriffsrechte vergeben habe. In erstem scheint der Fehler
ersichtlich:

libiomp5.so kann nicht gefunden zu werden.

Ist das ein bekanntes Problem?

Freundliche Grüße
RalphG
Dateianhänge
(192.3 KiB) Noch nie heruntergeladen
(289.94 KiB) Noch nie heruntergeladen
#3453
Hallo RalphG,

hmm...komisch. Hast du Z88Aurora schon mal neu heruntergeladen & installiert?
Hab grade eine VM mit Ubuntu 17.04 aufgesetzt, um das zu testen.
Frisches OS, mit Synaptic die passenden Pakete nachgeladen, Z88Aurora V4 heruntergeladen, installiert nach Handbuch, läuft (siehe Screenshot). Kann also nicht am Programm selbst liegen, der Fehler befindet sich irgendwo auf dem Weg Download-Installation-Betriebssystem.

Daher meine Empfehlung: Ordner komplett löschen, Pakete kontrollieren (ob alles installiert ist), Restart, neuer Download von Z88Aurora, nochmal nach Installationshandbuch installieren.

Wenn der Fehler dann noch auftritt, dann muss ich mal unsere Linux-Profis befragen :roll:

Grüße,
SHautsch
Dateianhänge
(235.85 KiB) Noch nie heruntergeladen
#3458
Hallo SHautsch,

nun funktioniert alles.

Beim wiederholten Installieren ist mir aufgefallen, dass ich ein Paket
übersehen hatte bei der Erstinstallation. Vermutlich lag hier der Fehler.

Vielen Dank nochmals für die intensive Hilfe!

Freundliche Grüße
RalphG
Beispiel2 Kranträger

Vielen Dank für den HInweis, habe zwar alles […]

I have imported step file. As i try to mesh with n[…]

Vernetzung von .stl-Dateien

Hallo Olegator, es gibt einige Freemesher, welche[…]

Hallo jenja, danke für Ihre Anfrage. Kö[…]