Z88 install problem on OS X Snow Leopard

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

Antworten
stu
Newbie
Beiträge: 2
Registriert: Sa 23. Okt 2010, 23:02
Kontaktdaten:

Z88 install problem on OS X Snow Leopard

Beitrag von stu »

Hi - my apologies for not presenting this in German.

I have installed Z88 on a MacPro running OS X 10.6.4. At first I had a lot of trouble sorting out the contents of opt/local/lib since that already contains a lot of stuff and just replacing it was not an option. But I think that one is solved by adding the unique libs provided that I did not have.

However when I run aurorastart I get the messages shown below. The X11 windows (2) open, but close after a few seconds.

Any assistance would be much appreciated.

Stu

Terminal output:


SEsMacPro:mac stu$ aurorastart
/opt/local/bin:/opt/local/sbin:/usr/local/Trolltech/Qt-4.3.4/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/texbin:/usr/local/bin:/Applications/Octave.app/Contents/Resources/bin:/usr/brlcad/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/visit/1.5.4/darwin-ppc/bin:/usr/local/bin:/model/mf2k.1_15/bin:/Users/stu/qt-mac:/System/Library/Perl/Extras/5.8.8:/Library/Perl/5.8.8:/Users/stu/dd_np:.
C
/Users/stu/z88aurorav1/addons/geocon/mac
Z88Aurora: Status: started
All memory allocated: 846 MB
Xlib: extension "RANDR" missing on display "/tmp/launch-Mx6XX6/org.x:0".
dyld: lazy symbol binding failed: Symbol not found: _cairo_xlib_surface_create
Referenced from: /opt/local/lib/libgdk-x11-2.0.0.dylib
Expected in: /opt/local/lib/libcairo.2.dylib

dyld: Symbol not found: _cairo_xlib_surface_create
Referenced from: /opt/local/lib/libgdk-x11-2.0.0.dylib
Expected in: /opt/local/lib/libcairo.2.dylib

/usr/bin/aurorastart: line 11: 37078 Trace/BPT trap z88aurora
SEsMacPro:mac stu$

Benutzeravatar
Z81
Alumni
Beiträge: 62
Registriert: Mi 9. Dez 2009, 15:50

Beitrag von Z81 »

Dear stu,
no problem we're not too bad in English. According to your error message a file is missing.
Have you installed our GTK package (available on our homepage) or do you have installed
any other programs in need of GTK?
If so please install the gtk4z88.tar.gz file and read the contribution
http://www.z88.uni-bayreuth.de/php/view ... ?p=378#378
where we already diskussed procedures to handle GTK-problems.
I hope that helped.

Regards,
Z81

stu
Newbie
Beiträge: 2
Registriert: Sa 23. Okt 2010, 23:02
Kontaktdaten:

Beitrag von stu »

Dear Z81

Thanks - that worked.

Best

Stu

Benutzeravatar
Z81
Alumni
Beiträge: 62
Registriert: Mi 9. Dez 2009, 15:50

Beitrag von Z81 »

You're welcome.

Regards,
Z81

Antworten