Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

Benutzeravatar
vom Z81
#463
Dear Danilo,

it seems the pango-folder within the gtk-package was not installed properly.
Does the opt/local/etc/pango folder exist? Which files are inside?

Regards,
Z81
vom Danilo
#464
Yes, that folder exists and contains:
  • pango.modules
    pangorc
    pangox.aliases
The first time I've extracted the GTK+ package by double-clicking it and moving in the right folder, because there was the new X11 folder in the /opt folder and Stuffit Expander created a folder /opt 2, which I thought is wrong and useless. When I move the local folder the mac ask for authentication, is that normal?
The second time (re-installation) I've extracted the tar by command line and folders were created automatically and in the right place.

I tell you as much as I know, hoping is not useless information. Thanks for the support.
Benutzeravatar
vom auroraIco
#466
Hi Danilo,

another idea: there is a z88.fcd in the directory z88auorav1/bin/mac. It begins like this:

WINDOW START
-----------------------------------------------------------------------------------
IW_DRAWAR 640
IH_DRAWAR 512
PANGO_FONT Arial
PANGO_SIZE 10
DEPTH_SIZE 1
WINDOW END

-----------------------------------------------------------------------------------
OPENGL START

Please change the font from "Arial" to "San". Does it work?

Best regards,

Aurora_ico
vom Danilo
#468
No, it doesn't :(

Regards
Danilo
Benutzeravatar
vom Z81
#469
Dear Danilo,

if you are operating another "opt" folder you can do the following trick,
in order to keep both, the old and the new one:
open a Terminal (Go > Applications > Utilities > Termial)

prompt cd / (go to the uppermost directory)
sudo mv opt opt_old (move your old "opt"-directory to "opt_old")

Now extract the gtk+package (also in this directory) by
sudo tar -xvzf gtk4z88.tar.gz
which extracts the files to "opt".

now move "our" opt to e.g. "opt_z88" by
sudo mv opt opt_z88

Having two opts you have to decide which one you want to use.

If you need the Z88 opt, type
sudo ln -s opt_z88 opt (create a link from "opt_z88" to "opt")

Now Z88 Aurora ought to work.

If you need the other opt delete the opt-link by
sudo rm opt

and create the opt_old link similar to the description in the first place.

I hope that helps!

Regards,
Z81
vom Danilo
#472
Thanks for the suggestion Z81, but I think is not possible: I have only one opt folder but in this folder coexist both X11 and the local folder. Creating two opt folder and switching between them could lead to "malfunction" since Aurora needs X11 to start.

Regards
Danilo
Benutzeravatar
vom Z81
#473
Dear Danilo,

I don't think that will be the case. You're right, you need a X11-Server
to run Z88, but if you have 10.6.6 Snow Leopard - there already is one
(/usr/X11/..) included; since 10.5 Leopard to be precise.
The XQuartz project is an open-source effort to develop a version of
the X.org X Window System that runs on Mac OS X. Together with
supporting libraries and applications, it forms the X11.app that Apple has
shipped with OS X since version 10.5.

Reference: http://xquartz.macosforge.org/trac/wiki

On our Macs there is no additionally X11 installed and Z88 Aurora runs
perfectly. As we've quite exploited the other possibilities, perhaps it is
that xquartz software. As far as I know for "wine" you just need Apple's
XCode and macports (www.macports.org).

Regards,
Z81
vom Danilo
#474
Done as suggested (two separated opt folders) and made X11 the default X-Server again, but the error still remains. Moreover, before having the Pango Font error window, there's a notification:
Code: Alles auswählen
Xlib:  extension "RANDR" missing on display "/tmp/launch-9fni8E/org.x:0".
Same after logout/login and restart, with Arial or San font in z88.fcd.
Take your time gentlemen, I just want to spend some of my free time in learning this FEA software, I don't like to be restrained to MSC Patran and other Windows running software.

Regards
Danilo
Benutzeravatar
vom auroraIco
#475
fortunately, I have a similar configuration and operating system on my mac so we can try to simulate your problem. we will see... for us it is a challenge to solve your problem. 8)

bye for now,

aurora_ico
vom ccad
#477
Dear Danilo,

the "error"-message Xlib: extension "RANDR" missing on display "/tmp/launch-9fni8E/org.x:0" is not critical but normal behavior on Mac OS X systems. You may skip it.

As the other AURORA team members said, your problem is quite strange and it appears to me that this is a problem of your X-server. Have you any possibilities to install a clean out-of-the-box Mac OS X 10.6.6? I'm sure that this will solve your special problem.
vom Danilo
#482
Dear ccad,

actually I can't. Also I uninstalled Aurora and XQuartz, then restarted the system and re-installed Aurora: the problem remains.

I will ask to my colleagues to try Aurora on their Macs, especially the one who has XQuartz installed on Leopard. I'll return here when something happens. Thank you all again for your time.

Best regards
Danilo
vom Danilo
#485
Problem SOLVED!

After several tries I had a suspect: why the X server should be the problem if the error advice is about the font? So I remembered that time ago I did a little mess installing a huge font package :roll: However Arial is present and any duplicate issue was already solved. So... I don't know why, I changed the Pango Font in z88.fcd from Arial to Times (instead of San). And it works!

I hope to fully enjoy your software soon. Best regards.
Danilo
Benutzeravatar
vom Z81
#489
Dear Danilo,

we're glad it finally works. So aurora_ico's first proposal to change the fonts
was correct. Unluckly the standard font wasn't avaiable as it should. Well,
we're glad we could help!

Have fun with Z88 Aurora!
Best regards,
Z81
vom JukkaTer
#570
pekka hat geschrieben::D
Yes, the program is now up and running!
The mac-folder contained files z88_de.dyn and z88_en.dyn. I just changed the name of the other file to z88.dyn and that did the trick.

Dear Z81, once again, many thanks for your help!
Regards, Pekka
Hi! I just tried to install the z88 aurora and have the same problem as described here. Replacing the z88.dyn did not help in my case. The console window:
----------
Last login: Tue Apr 5 14:02:26 on ttys000
[Macintosh-2:~] tervis% aurorastart
/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:.
C
/Users/tervis/z88aurorav1/addons/geocon/mac
/usr/bin/aurorastart: line 11: 2179 Segmentation fault z88aurora
[Macintosh-2:~] tervis%
-------------
The crash report to Apple:

Process: z88aurora [2179]
Path: /Users/tervis/z88aurorav1/bin/mac/z88aurora
Identifier: z88aurora
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: bash [2178]

Date/Time: 2011-04-05 14:07:05.761 +0300
OS Version: Mac OS X 10.6.7 (10J869)
Report Version: 6

Interval Since Last Report: 126927 sec
Crashes Since Last Report: 4
Per-App Crashes Since Last Report: 4
Anonymous UUID: 25ECA14C-9863-4655-A238-3BA8E8348ACC

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000068
Crashed Thread: 0 Dispatch queue: com.apple.main-thread
---------------
Now, I am completely helpless? What to try next?

Regards: JukkaTer
Benutzeravatar
vom auroraIco
#582
Hello JukkaTer,

it looks like you don´t have any writing permissions. First you can use sudo for start (terminal: sudo aurorastart) or you can check the permissions in /opt for gtk+, /opt and usr/bin for aurora. You can also sent us your permissions: go to the aurora directory (in your user account) open a shell and type " ls -l -R name.txt. Then sent this file to z88aurora@uni-bayreuth.de. do the same with the opt- and the user/bin directory.

Regards,

aurora_ico

Hallo Hanhart94, ich vermute der Fehler liegt bei[…]

Start

Hallo Schlorchi00, leider konnten wir den Fehler[…]

Hallo liebes Z88 Team, gibt es bereits Neuigkeite[…]

UPDATE Nachdem ich es nach weiteren Tests leide[…]