Jacobi-Determinante Null oder Negativ

Fragen zu Solvertypen, Multicore-Rechnungen, Spannungsparametern /
Issues to solvers, multi core, stress parameter

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

Antworten
Lukas
Newbie
Beiträge: 2
Registriert: Mi 20. Jul 2016, 13:13

Jacobi-Determinante Null oder Negativ

Beitrag von Lukas »

liebes z88-team.

erstmals vielen lieben dank für das tolle programm.
leider habe ich ein problem mit meinem bauteil, ein importiertes *.step-file aus freecad.
es lässt sich leider keine eigenschwinung berrechnen.
nach tetgen - habe unterschiedliche elementgrößen probiert - erhalte ich folgende fehlermeldung:

### Jacobi-Determinante Null oder negativ..Stop ###
### Elemente zu verzerrt oder falsch numeriert ###
### pruefen, Numerierung gegen Uhrzeigersinn? ###

freue mich über jede hilfe.
vielen dank,
liebe grüße,
lukas

Benutzeravatar
SHautsch
Alumni
Beiträge: 380
Registriert: Mo 15. Apr 2013, 11:03

Re: Jacobi-Determinante Null oder Negativ

Beitrag von SHautsch »

Hallo Lukas,

wie haben Sie denn das STEP-File vernetzt (Tetgen - welche Einstellung)?
Haben Sie den Netz-Check durchgeführt oder vorher den STL-Doktor?
Handelt es sich bei der Struktur um eine Baugruppe oder ein Bauteil?
Falls Sie eine Baugruppe importieren, so kann diese in Z88Aurora V3 nicht korrekt vernetzt werden - dafür müssen Sie auf die Version V4 warten, welche den Kontaktsolver mitbringt. Aktuell funktionieren nur einzelne Bauteile.

Viele Grüße,
SHautsch

Lukas
Newbie
Beiträge: 2
Registriert: Mi 20. Jul 2016, 13:13

Re: Jacobi-Determinante Null oder Negativ

Beitrag von Lukas »

hallo shautsch,

einstellungen waren tetgen (linear) bei einem wert von 20.
leider weiß ich nicht was der netz-check bzw. der stl-doktor ist, vielleicht können sie mir auch hierbei behilflich sein.
es handelt sich nur um ein bauteil.

vielen dank und liebe grüße,
lukas

Benutzeravatar
SHautsch
Alumni
Beiträge: 380
Registriert: Mo 15. Apr 2013, 11:03

Re: Jacobi-Determinante Null oder Negativ

Beitrag von SHautsch »

Hallo Lukas,

wenn Sie das Bauteil in Z88Aurora importieren, können Sie unter "Tools > STL bearbeiten" den STL-Doktor starten.
Falls Sie dort rote Flächen sehen, sind die STL-Oberflächen falsch orientiert. Picken Sie dann eine grüne Oberfläche, können Sie die STL-Datei reparieren.
Sieht das im STL-Doktor gut aus, dann können Sie nach der Vernetzung im Menü "Präprozessor > Vernetzung > Tetraeder" das erstellte Netz per Klick auf "Netz-Analyse" prüfen lassen. Kommt hier kein Fehler, sollte das Netz rechenbar sein.

Wenn Sie diese Schritte durchgeführt haben und der Fehler immer noch auftritt, können Sie uns das betroffene Projekt gerne gezippt hier oder per E-Mail an z88aurora-at-uni-bayreuth.de zukommen lassen, damit wir das Problem genau analysieren können.

Viele Grüße,
SHautsch

FEM5Neuling
Import
Beiträge: 18
Registriert: Di 16. Aug 2016, 11:31

Re: Jacobi-Determinante Null oder Negativ

Beitrag von FEM5Neuling »

Gibt es einen solchen Netzcheck auch für importierte Netze? genau die Fehlermeldung bekomme ich auch - siehe auch anderer Fred.

mifris
Alumni
Beiträge: 153
Registriert: Mo 27. Sep 2010, 20:41

Re: Jacobi-Determinante Null oder Negativ

Beitrag von mifris »

Hallo FEM5Neuling,

einen Netzcheck (= ob das FE-Netz rechenbar ist) kann man auch in Z88 mit importierten FE-Strukturen durchführen. Hierfür im Präprozessor einfach auf "Vernetzung --> Tetraeder" klicken und Netz-Analyse auswählen. Danach erscheint ein Fenster, das Dir sagt, ob das FE-Netz rechenbar ist oder nicht. :)

Viele Grüße
M. Frisch

Antworten