Das Forum zu Z88OS (Open Source) / The newsgroup for Z88OS (open source)

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

vom flogri
#228
Hallo Z88ler!!

Ich arbeite mich zur Zeit ganz frisch in die FE-Modellierung ein und stehe nun prompt vor einem Problem, das ich nicht verstehe. Ich habe einen Ausschnitt eines Evolventen-Stirnrades in 2D modelliert. Beim Ausf?hren des Z88x erkennt er alle Knoten und auch alle Elemente. Die Superstruktur ist Scheibe NR. 11. Der einzigste Fehler ist die korrekte Abfolge des Elements Nummer 3. Ab der n?chsten Zeile beginnt ein kleiner Ausschnitt aus der z88x.txt-Datei:
...
ELE2 #4 J=1 XK=-47.1397 YK=88.1921 ZK=0
ELE2 #5 J=2 XK=-44.5191 YK=89.5436 ZK=0
ELE2 #6 J=3 XK=-41.4249 YK=91.0163 ZK=0
ELE2 #7 J=4 XK=-38.2683 YK=92.388 ZK=0
ELE2 #40 J=5 XK=-60.5914 YK=146.281 ZK=0
ELE2 #53 J=6 XK=-82.9149 YK=200.174 ZK=0
ELE2 #70 J=7 XK=-105.238 YK=254.067 ZK=0
ELE2 #69 J=8 XK=-113.124 YK=250.655 ZK=0
ELE2 #68 J=9 XK=-121.868 YK=246.522 ZK=0
ELE2 #67 J=10 XK=-129.634 YK=242.528 ZK=0
ELE2 #52 J=11 XK=-102.136 YK=191.083 ZK=0
ELE2 #39 J=12 XK=-74.6377 YK=139.637 ZK=0
ELE3 #7 J=1 XK=-38.2683 YK=92.388 ZK=0
ELE3 #8 J=2 XK=-35.0664 YK=93.6501 ZK=0
ELE3 #9 J=3 XK=-31.8371 YK=94.7966 ZK=0
ELE3 #41 J=4 XK=-45.9616 YK=151.515 ZK=0
ELE3 #54 J=5 XK=-62.8951 YK=207.337 ZK=0
ELE3 #73 J=6 XK=-79.8283 YK=263.159 ZK=0
ELE3 #73 J=7 XK=-79.8283 YK=263.159 ZK=0
ELE3 #72 J=8 XK=-88.1434 YK=260.491 ZK=0
ELE3 #71 J=9 XK=-97.2493 YK=257.231 ZK=0
ELE3 #70 J=10 XK=-105.238 YK=254.067 ZK=0
ELE3 #53 J=11 XK=-82.9149 YK=200.174 ZK=0
ELE3 #40 J=12 XK=-60.5914 YK=146.281 ZK=0
ELE4 #10 J=1 XK=-29.0285 YK=95.694 ZK=0
ELE4 #11 J=2 XK=-26.455 YK=96.4372 ZK=0
ELE4 #12 J=3 XK=-23.5271 YK=97.193 ZK=0
ELE4 #13 J=4 XK=-19.485 YK=98.0197 ZK=0
ELE4 #42 J=5 XK=-30.8832 YK=155.285 ZK=0
ELE4 #55 J=6 XK=-42.2519 YK=212.491 ZK=0
ELE4 #76 J=7 XK=-53.6499 YK=269.716 ZK=0
ELE4 #75 J=8 XK=-62.5056 YK=267.802 ZK=0
ELE4 #74 J=9 XK=-71.6882 YK=265.492 ZK=0
ELE4 #73 J=10 XK=-79.8283 YK=263.159 ZK=0
ELE4 #54 J=11 XK=-62.8951 YK=207.337 ZK=0
ELE4 #41 J=12 XK=-45.9616 YK=151.515 ZK=0
...
Wie man unschwer erkennen taucht der Knoten 73 2mal auf, daf?r fehlt der Knoten 10 (zwischen Knoten 9 und Knoten 41). Dieser Knoten wird komischerweise aber im darauffolgenden Element richtig erkannt.

Ich hoffe, ihr k?nnt mir weiterhelfen!!

viele Gr??e,
Flo
Benutzeravatar
vom Troll
#229
Guten Tag flogri,

erst einmal willkommen auf dieser Seite.

Hier ein m?glicher L?sungsvorschlag:

In der dxf-Datei die Linie, die das Element 3 beschreibt,
l?schen und noch einmal erstellen. Mein Verdacht ist, dass der Knoten
73 zweimal gefangen oder angeklickt wurde und daher der letzte
gew?nschte Knoten fehlt. Das w?re eine M?glichkeit, die den Fehler erkl?rt.
Eine R?ckmeldung w?rde mich freuen.

Mit freundlichen Gr??en

Troll
vom flogri
#230
Hallo Troll!!

Ich habe den Fehler vorhin gefunden. Ich habe einfach alle Linien gel?scht und noch einmal alle Linien nachgezeichnet. Dabei ist mir aufgefallen, dass bei dem Fangmodus bei Autocad 2 Arten existieren: entweder taucht der Begriff "Endpoint" auf oder eben "Intersection" auf. Ich habe also bei dem ersten Mal, wo ich die Linien zeichnete, aus Versehen bei dem Element Nr. 3 den Mausklick bet?tigt, als der Begriff "Intersection" und nicht als "Endpoint", wie es eigentlich richtig ist, auf dem Bildschirm stand.
So langsam habe ich den Dreh raus :) !!

Trotzdem vielen Dank f?r die Antwort!!

Viele Gr??e,
flogri

Hallo, ich habe ein paar Probleme, bei der Berec[…]

Start

Hallo Schlorchi00, leider konnten wir den Fehler[…]

Hallo liebes Z88 Team, gibt es bereits Neuigkeite[…]

UPDATE Nachdem ich es nach weiteren Tests leide[…]