Das Forum zu Z88OS (Open Source) / The newsgroup for Z88OS (open source)

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

vom Alexvader
Hi forum, I have downloaded the source code from latest version of Z88, and tried to build an executable for 8.10amd64, but i cannot manage to compile the binaries, I run into this mistake :

lan88h.c: In function ?lan88h?:
lan88h.c:74: warning: built-in function ?clog? declared as non-function
gcc -march=athlon64 -I. -I/usr/X11R6/include -DFR_UNIX -DFR_XDOUB -DFR_LINUX -O3 -fomit-frame-pointer -c -o rdy88h.o rdy88h.c
gcc -o z88h z88h.o ale88h.o clr88.o stop88h.o who88h.o wlog88h.o wrim88h.o lan88h.o rdy88h.o -lc
gcc -march=athlon64 -I. -I/usr/X11R6/include -DFR_UNIX -DFR_XDOUB -DFR_LINUX -O3 -fomit-frame-pointer -c -o z88p.o z88p.c
z88p.c:52:22: error: Xm/XmAll.h: No such file or directory
z88p.c:58: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?hmain?
z88p.c:59: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?hform?
z88p.c:60: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?hw?
z88p.c:94: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?hgc?
z88p.c:148: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?WindowProcedure?
z88p.c:150: error: expected ?)? before ?hcallw?
z88p.c:152: error: expected ?)? before ?hcallw?
z88p.c:155: error: expected ?)? before ?hcallw?
z88p.c:158: error: expected ?)? before ?hcallw?
z88p.c:160: error: expected ?)? before ?hcallw?
z88p.c:162: error: expected ?)? before ?hcallw?
z88p.c:164: error: expected ?)? before ?hcallw?
z88p.c:166: error: expected ?)? before ?hcallw?
z88p.c:168: error: expected ?)? before ?hcallw?
z88p.c:170: error: expected ?)? before ?hcallw?
z88p.c:172: error: expected ?)? before ?hcallw?
z88p.c:175: error: expected ?)? before ?hcallw?
z88p.c:177: error: expected ?)? before ?hcallw?
z88p.c:179: error: expected ?)? before ?hcallw?
z88p.c:181: error: expected ?)? before ?hcallw?
z88p.c:183: error: expected ?)? before ?hcallw?
z88p.c:185: error: expected ?)? before ?hcallw?
z88p.c:187: error: expected ?)? before ?hcallw?
z88p.c:190: error: expected ?)? before ?hcallw?
z88p.c:192: error: expected ?)? before ?hcallw?
z88p.c:195: error: expected ?)? before ?hcallw?
z88p.c:198: error: expected ?)? before ?hcallw?
z88p.c:201: error: expected ?)? before ?hcallw?
z88p.c:204: error: expected ?)? before ?hcallw?
z88p.c:206: error: expected ?)? before ?hcallw?
z88p.c:208: error: expected ?)? before ?hcallw?
z88p.c:210: error: expected ?)? before ?hcallw?
z88p.c:212: error: expected ?)? before ?hcallw?
z88p.c:214: error: expected ?)? before ?hcallw?
z88p.c:217: error: expected ?)? before ?hcallw?
z88p.c:220: error: expected ?)? before ?hcallw?
z88p.c:308: warning: built-in function ?clog? declared as non-function
z88p.c: In function ?main?:
z88p.c:320: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?hmain?
z88p.c:320: error: ?hmain? undeclared (first use in this function)
z88p.c:320: error: (Each undeclared identifier is reported only once
z88p.c:320: error: for each function it appears in.)
z88p.c:322: error: ?Widget? undeclared (first use in this function)
z88p.c:322: error: expected ?;? before ?MainDialog?
z88p.c:324: error: ?XtAppContext? undeclared (first use in this function)
z88p.c:324: error: expected ?;? before ?app_context?
z88p.c:331: error: ?app_context? undeclared (first use in this function)
z88p.c:333: error: ?MainDialog? undeclared (first use in this function)
z88p.c: At top level:
z88p.c:345: error: expected ?=?, ?,?, ?;?, ?asm? or ?__attribute__? before ?WindowProcedure?
make: *** [z88p.o] Error 1
****** Done Z88 for LINUX 64-Bit *******

Can someone help me...?

Thanks in advance

Best regards

vom ccad
Hello Alexvader,

the problem is: the Motif development library is missing (see first error message: Xm/XmAll). You should load from the Internet OpenMotif, especially the development libraries.

And this may be a problem with Ubuntu: Ubuntu is great - as a comfortable end user system. I like it, really. But for software development a couple of precompiled libraries is missing. By the way: i tried to compile Z88 on an Ubuntu system half a year ago and it did not work because of missing development libraries. This is why we work at the University of Bayreuth, Germany with OpenSuse. Fedora should work, too.

Sorry - but if you won't find the prebuild Motif libs on the internet then you have only one chance: get the OpenMotif sources and try to build the nessesary libs.

Good luck!

vom ccad
Hello Alexvader,

here's another way to solve your problem: Download the brandnew Z88 Version 13 from www.z88.de. The new LINUX Z88 works now with GTK+, not - as in former releases - with Motif. GTK+ should present no problems with Ubuntu.

vom Alexvader

Been away for a while, thank you for your answer... I will try Z88 13...

Just one more question, can Z88 handle multibody assemblies connected by rigid links, like bolts, weld beads and rivets ( I was thinking defining separate meshes for each body and connecting them by discrete elements like tension/shear springs for bolts/rivets... ) can this be done in Z88...?

best regards


I have changed from Ubuntu also... to Debian 5.0 amd64, Ubuntu It is a bit buggy form my taste, great distro though, if one is not very experienced in Linux...

Never used (Open)Suse.... after the " dependency Hell" I used to experience with RHEL 4 ( the first linux I ever used ) I use an rpm based distro if one points a gun to my head... :-)

Will start to use Z88 now...and read the manual to find something about connection elements... bolts, weld beads, rivets...

Without these I cannot model real structures, only components... :-(

Best regards


Dear samshah, what CAD system do you use? Maybe y[…]

Hello Mr. Gillies, the boundary conditions are al[…]

Beispiel2 Kranträger

Vielen Dank für den HInweis, habe zwar alles […]

Vernetzung von .stl-Dateien

Hallo Olegator, es gibt einige Freemesher, welche[…]