Das Forum zu Z88OS (Open Source) / The newsgroup for Z88OS (open source)

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

#209
Hallo zusammen,

ich hab ein kleines Problem bei meinem Modell und hoffe es kann mir jemand dabei helfen.

Das Modell l?sst sich zun?chst erst mal mit beiden Plot-Programmen darstellen und auch der Filechecker erkennt keinen Fehler bei den Z88-Eingabedateien.
Als ich jedoch den Rechenlauf gestartet habe, tritt folgende Fehlermeldung auf: ?Diagonalelement im Gleichungssystem Null oder negativ!?. Diese erscheint sowohl beim Verwenden des direkten als auch des Iterationssolver. Das Programm schl?gt mir vor, die Randbedingungen zu ?berpr?fen und bricht auch den Rechenlauf nach Einlesen der Randbedingungen ab. In der *.log-Datei ist weiterhin angegeben, dass der Fehler beim Diagonalelement 446 auftritt.
Das Variieren der Randbedingungen ergab jedoch keinen Erfolg beim Durchlauf der Rechnung.

F?r eure Hilfe, vielen Dank im Voraus.

MfG Martin
Benutzeravatar
vom Troll
#210
Hallo Martin,

hoffentlich kommt die Hilfe nicht schon zu sp?t.

Erst mal einige kleine Fragen, damit ich das besser einsch?tzen kann:

1. Ist das Modell wirklich statisch bestimmt oder ?berbestimmt?
(Ist z.B. ein Knoten in allen Freiheitsgraden festgehalten um ein Lager darzustellen)
2. Ist es ein Modell aus Strukturelementen (Balken, Wellen, etc.) oder aus
Kontinuumselementen (Tetraeder, Hexaeder, etc)?

Dahinter steckt folgende ?berlegung:

Der Filecheker ist f?r syntaktische Fehler oder fehlende Werte zust?ndig, kann aber nicht abpr?fen, ob tats?chlich ausreichende Randbedingungen vorliegen. Wenn die Randbedingungen nicht ausreichen dann wird die Fehlermeldung
?Diagonalelement im Gleichungssystem Null oder negativ!?.
folgen. ==> nicht ausreichend gelagert.

Wenn es sich um eine Struktur aus Hexaedern, Tetraedern oder Platten handelt dann kann diese Fehlermeldung erscheinen, wenn die Reihenfolge f?r die Knoten in der Koinzidenzliste nicht eingehalten wurde. Im Z88-Handbuch ist f?r jedes Element die Knotenreihenfolge angegeben. Dieser
Fehler passiert besonders dann gerne, wenn eine 3D-Struktur von Hand erstellt wurde. Dies k?nnte man einmal nachpr?fen.

Ich hoffe ich konnte erst einmal helfen; genaueres kann ich erst sagen, wenn ich mehr Infos ?ber die verwendete Struktur habe

Gr??e

Troll
vom martin
#211
Hallo Troll,

mein Modell besteht aus Hexaeder-Elementen mit 8 Knoten. Eingespannt ist es durch die Sperrung der Verschiebung von mehreren Knoten in alle drei Raumkoordinaten.
Die Knoten und Elemente wurden automatisch generiert. Diese wurden von mir den Z88-Eingabedateien angepasst. Dabei traten anfangs Fehlermeldungen wegen falscher Reihenfolge der Koinzidenz der Elemente auf. Bei dieser Fehlermeldung wurden die betroffenen Elemente nacheinander angezeigt, wodurch das Modell korrigiert werden konnte. Die jetzige Fehlermeldung ist jedoch eine andere, bei der ich bis jetzt keine L?sung gefunden habe.

Um mich dem Problem anzun?hern, habe ich mein Modell soweit vereinfacht, so dass es nur aus einer Elementschicht besteht. Dabei sind keine Fehler im Aufbau der einzelnen Elemente ersichtlich, aber die Fehlermeldung erscheint weiterhin.
Da mir auch bei den Randbedingungen nichts Ungew?hnliches aufgefallen ist, wei? ich nicht weiter.

Mit freundlichen Gr??en

Martin
Benutzeravatar
vom Troll
#212
Hallo Martin,

der Fall ist schon etwas interessanter.
Die Randbedingungen sollten ausreichend sein und wenn
die Knotenreihenfolge schon angepasst wurde, dann ist eine
typische Fehlerquelle eleminiert.

W?re es vielleicht m?glich, dass Sie mir die Eingabedaten
(i1, i2, i5) einmal zuschicken? Meine Mailadresse lasse ich Ihnen
mit einer PN zukommen.

Gr??e

Troll
vom Martin_M
#382
Tritt bei mir auf bei einer Platte die an allen 4 Ecken eingespannt ist

14
1 1 2 0.000000
1 2 2 0.000000
1 3 2 0.000000
31 1 2 0.000000
31 2 2 0.000000
31 3 2 0.000000
466 3 1 -500.000000
496 3 1 -500.000000
931 1 2 0.000000
931 2 2 0.000000
931 3 2 0.000000
961 1 2 0.000000
961 2 2 0.000000
961 3 2 0.000000


gibt es dazu schon eine L?sung?
Vielen Dank im Voraus
vom mifris
#383
Hallo Martin_M.

Haben Sie die Eingabedateien per Hand eingegeben? Dieser Fehler kann evtl.auftreten, wenn in der Z88i1.txt die Nummerierung der Elemente falsch ist. Um genauere Aussagen zu treffen w?rde ich Sie bitte die Eingabedatei Z88i1.txt zu posten oder an michael.frisch@uni-bayreuth.de zu schicken.
Dann k?nnen wir genauere Aussagen treffen.

Mit freundlichen Gr??en.

Hallo Hanhart94, ich vermute der Fehler liegt bei[…]

Start

Hallo Schlorchi00, leider konnten wir den Fehler[…]

Hallo liebes Z88 Team, gibt es bereits Neuigkeite[…]

UPDATE Nachdem ich es nach weiteren Tests leide[…]