Das Forum zu Z88OS (Open Source) / The newsgroup for Z88OS (open source)

Moderatoren: ccad, mz15, auroraIco, Lehrstuhl

#196
Hallo,

ich habe ein Bauteil mit Elementen Typ 7 vernetzt. Aufgrund hoher Knoten- und Elementanzahl benutze ich zum L?sen z88i1.exe und z88i2.exe und damit ergeben sich mit angepasster Genauigkeit eps auch eine sinnvolle L?sung der Verschiebung. Beim Berechnen der Spannung erscheint dann die Fehlermeldung "Jacobi-Determinante kleiner gleich 0". Aufgrund meiner FEM-Kenntnisse ist es doch so, dass die Jacobi-Determinante nur kleiner gleich null werden kann, wenn die Knoten im Element im Uhrzeigerzinn angeordnet sind oder das Element sich durchdringt. Dieses ist bei mit nicht der Fall. Was mich am meisten wundert, ist die Tatsache, dass beim Aufstellen der Gesamtsteifigkeitsmatrix innerhalb z88i1 und z88i2 die Jacobimatrix auch schon f?r jedes Element aufgestellt werden muss und schon da ein Fehlermeldung h?tte erscheinen m?ssen, w?re mit dem Element etwas nicht in Ordnung. Au?erdem passiert dies mal beim zweiten, mal beim 4 Element, wie man anhand der Ausgabedatei z8803.txt sehen kann. Daher meine Vermutung, es muss an einer gewissen Toleranz f?r die Jacobideterminate liegen oder ein anderer Bug enthalten sein.

Wenn jemand dieses Problem kennt oder eine L?sung anbieten kann, dann einfach einen Kommentar schreiben. Danke f?r eure Hilfe

Julia
vom Zimmermann
#197
Guten Tag Julia,

Es ist durchaus m?glich, dass so etwas passieren kann.

Die erste M?glichkeit hierzu w?re: Sind die Modelle, die berechnet werden sehr klein, so dass sehr kleine Jacobideterminanten entstehen ? D.h. liegen die Elementgr??en im Bereich 10E-8 oder kleiner ?

Ein weiterer Schl?ssel zu diesem Problem kann die eingestellte Integrationsordnung sein. Diese kann in der Datei z88i3.txt f?r die Spannungsberechnung seperat zu der der Verschiebungsberechnung eingestellt werden. Eventuell ist die f?r die Spannungsberechnung gr??er eingestellt als die f?r die Verschiebungsberechnung des z88i2-Solvers. Hiezu kann in der Hilfe nachgeschaut werden, wie die Integrationsordnung f?r die Elemente einzustellen ist.

Im ?brigen k?nnen auch f?r stark verzerrte Elemente in den St?tzstellen negative Jacobideterminaten auftreten. (Elementaufl?sung erh?hen)

Sollte alles das nichts helfen, schicken Sie uns doch bitte die Eingabedateien, vielleicht erkennen wir dann den Fehler.

Mit freundlichen Gr??en

Martin Zimmermann

Hallo zusammen, ich habe leider Probleme beim Impo[…]

Z88Aurora V5 released

Hey Dave, thank you for your feedback. We are gl[…]

Hallo Herrjakel, Ihr System ist eigentlich schon […]

Hallo ich versuche ein eine etwas komplizierteres[…]